El mensaje de error "Parece que a su instalación de PHP le falta la extensión de MySQL que requiere WordPress" puede aparecer cuando está usando una versión de PHP que es incompatible con la versión de su script (su instalación de WordPress probablemente esté desactualizada).
Dado que la extensión de MySQL está en desuso (ya no se admite) de PHP 7.0 y posteriores, el cambio de su versión de PHP a 5.6 o inferior solucionará el problema.

Esto se puede hacer a través de la sección Configuración de PHP del panel de control de su sitio web .

NOTA : La mejor solución sería actualizar su instalación de WordPress. Para saber exactamente cómo puede hacerlo, consulte este tutorial :) 

¿Encontró su respuesta?