Magento 2.3 y anteriores

Recientemente, mejoramos nuestra versión de MariaDB de 10.3 y 10.4 a 10.5 en todos los servidores compartidos y en la nube. Como Magento aún no admite oficialmente MariaDB 10.5, si intentas instalarlo a través de nuestro instalador automático, verás un error como este:

Error: The selected version 2.3.6 is not compatible with the selected install location.Requirements:mariadb 10.2-10.3.99 (detected: 10.5.12)

¡No te preocupes, sabemos cómo proceder! ¡Simplemente, sigue los pasos a continuación y tendrás Magento instalado en tu cuenta de hosting en muy poco tiempo!

PASO 1: instalar Magento manualmente

Lo primero que deberás hacer es instalar Magento manualmente, para eso puedes consultar este tutorial: Cómo instalar Magento 2.xx manualmente.

PASO 2: edita el archivo de configuración

Después de instalar Magento, deberás abrir el directorio app/etc y abrir el archivo di.xml para editarlo (simplemente haz doble clic en él):

Una vez allí, tendrás que encontrar esta línea:

<item name="MariaDB-(10.2-10.4)" xsi:type="string">^10\.[2-4]\.</item>


Y reemplázalo por esta:

<item name="MariaDB-(10.2-10.5)" xsi:type="string">^10\.[2-5]\.</item>


Puedes encontrar un ejemplo aquí: Actualizar di.xml para admitir MariaDB 10.5.x #33111

¡Eso es todo! Una vez que guardes los cambios, tu sitio web de Magento empezará a funcionar correctamente.

NOTAS:

  • Más tarde se lanzará una solución permanente. Por ahora, procede amablemente con estos pasos para la instalación de Magento.

  • Según el sitio web oficial, la fecha de finalización del soporte de software para Magento Commerce 2.3 se extendió hasta abril de 2022 debido a los impactos de COVID-19. Esto significa que después de abril de 2022, Magento 2.3 y las versiones anteriores ya no serán compatibles y no se recomienda su uso.

Magento 2.4 y superior

Magento 2.4 y superior solo se puede usar en planes VPS debido a que Elasticsearch es uno de los requisitos, y solo está disponible en planes VPS.

¿Encontró su respuesta?